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Day 2 

1. What is Zonae Cogito?  

Zonae Cogito (ZC) is software designed as a decision support system and database 

management system to supplement the Marxan software. It incorporates open-source GIS 

software components, and is a freely available software package.  See the ZC user 

manual for more detailed information (located in C:\IntroMarxan\documents). 

 

In ZC you can: 

 Edit Marxan some parameters and input files 

 Run Marxan analyses 

 Interactively view the results of Marxan analyses 

 Interactively make changes to Marxan solutions 

 Calibrate Marxan parameters 

 Run the full range of Marxan software (including Marxan, Marxan with Zones, 

Threat Probability, and cluster analysis of Marxan solutions) 

 Use as the GIS for the C-Plan Conservation Planning System 

 

 

2. Creating a backup database 

Before creating a new ZC project it is good practice to create a backup copy of all of your 

work.  This way if something happens or you make changes you will have a clean 

original copy ready to work with.   

We did this step the day before by creating the folder Marxan_database_backup.   

 

3. Scenarios in ZC 

Most Marxan analyses will require you to explore a number of slightly different problem 

definitions that have varying conservation feature targets, cost layers, groups of 

conservation features and/or clumping. It is rare that only one problem definition will be 

run to inform a conservation plan. We refer to these different problem definitions (with 

one or more different “key” parameters) as scenarios.   

 

Another important definition for Zonae Cogito is the project. A project links Zonae 

Cogito to Marxan, the current scenario database, and the current scenario’s copy of the 

planning unit shapefile. Any edits you make to a project are written directly to that 

scenario’s input files (writing over what was previously there!). This is why it is 

important to have a backup database, so that you can work backwards if you make a 

change to the input files, run Marxan, and realize that you didn’t want to make that 

change. 

 

An example: your aim is to create a comprehensive, adequate, representative, and 

efficient marine reserve network in your study region. You might explore adequacy by 

having different scenarios with varying conservation feature targets. When you change 

the target level (perhaps 20%, 30% and 50% of the current extent of your conservation 
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features) to compare the results, you will need to run Marxan with each of those targets. 

You cannot run all 3 target levels in the same Zonae Cogito project because when you 

change the target and re-run Marxan, the results will write over the previous results. So 

each scenario needs its own project to link what you are doing in Zonae Cogito to the 

correct version of the database and the planning unit shapefile.   

 

It is good practice to start every new scenario (i.e. every time you are changing a key 

parameter like the target level) with the following steps:  

 

 Create a new folder with the scenario name   

 Copy the entire contents of the Marxan_database folder into the scenario folder  

 Create a new project to link Zonae Cogito with your new database and shapefile – 

the old file is still connected 

 

After you have created a new scenario, and linked a new project to it, you can safely edit 

your project. Sometimes you might want to “build” on a previous scenario (for example if 

you have calibrated the SPF or BLM). In this case you will need to put the calibrated 

input database into your new scenario, taking care to place a clean planning unit shapefile 

in your new scenario and to create a new project linking the new scenario to Zonae 

Cogito. 

 

 

4. Creating a new ZC project 

Start Zonae Cogito from the windows menu system like this: 

 

 Create a new folder in the IntroMarxan folder. Name it “exercise1” 

 Copy the entire contents of the Marxan_database folder into the exercise1 folder 

 Go to “Start” > “All Programs” > “Zonae Cogito” > “Zonae Cogito” 

 If Zonae Cogito is not in the start menu, browse to “C:\Program Files\Zonae Cogito” 

and double click on “ZonaeCogito.exe” to launch the software 

 From the ZC main menu select “File” > “New” to create a new ZC project 

 Give your project a name, e.g., “Test_Run1” 

 

For now it is alright to use any name, but when you begin to develop more complex 

scenarios it is important to develop a naming convention that allows you to easily identify 

the scenario.  If you have many different scenarios, it is also good to keep a master list 

indicating the costs, targets, and other parameters for each scenario. 

 

 Tick the box next to “Include Marxan Database” and then use the browse button to 

navigate to and select the input.dat file in “C:\IntroMarxan\exercise1\” 
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  

  

 Use the browse button next to the 

“Locate GIS Layers to Display” 

window to navigate to the 

pulayer folder in 

“C:\IntroMarxan\exercise1\Marx

anDatabase\”, and select 

“pulayer_BC_Marine.shp”  

 Confirm that 

“pulayer_BC_Marine.shp” is the 

file listed in the “Select Planning 

Unit Shapefile” drop down menu 

 Select “PUID” (or "PU_ID") 

from the drop down menu next to 

“Select planning unit key field”  

 Click OK to generate the new ZC project 

 

 

 
 

5. Resizing the ZC windows 

When you first open ZC, you will see two windows, the GIS display 

window and the Marxan window.  You might also notice that ZC does 

not fill your entire desktop.  

 

 To resize ZC, double click on the maximize window  

 After maximizing, from the ZC menu select “Window” > 

“Arrange” 

 Select “vertical” to re-arrange in the same manner, or “horizontal” 

to change the arrangement of the models 
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You will probably also have noticed the GIS window in ZC is currently blank.  Whenever 

you create a new project, the GIS window will appear blank until you have run Marxan 

for the first time (this is not always the case, however).  At this point it is also a good idea 

to save the Marxan project you have just created.  

 

6. Saving a ZC project 

 To save the project, select “File” > “Save” from the main ZC menu 

 

You will notice that whenever you create a new ZC project, it will create a file 

“<filename>.zcp” inside the Exercise1 folder.  This file can also be used to reopen a 

scenario, but it is best if you save the scenario with a name that reminds you what the 

scenario is.  After saving the scenario we are ready to run Marxan from ZC. 

 

7. Running Marxan 

 To run Marxan, click “Run” in the Marxan Box  

 After clicking run, you should see a process: 

 

After the run is complete, your planning unit layer 

will appear in the GIS window.  

Note: the ZC default setting is for viewing the 

available, rather than reserved, planning units). 

 

 

8. Viewing Marxan results 

 Results from an individual run can be displayed by selecting the run number from the 

drop down menu next to “Output to Map” in the GIS display 

 From the main menu select “Marxan” > “View Output” > “Summary Report” to 

display the summary information for all runs 

 Look at the Missing Values field as an indication of how many of your conservation 

features do not meet their targets in that solution – are your targets being met? 

 From the main menu select “Marxan” > “View Output” > “Best Solution” > “Report” 

to open the target achievement report for the solution with the lowest objective 

function score 

 Look through this file to see if your targets have been met in the “best” solution – if 

they are not, check the “MPM” field to indicate how close the target is to being met 

(1 = 100% met, 0.99 = 99% met, etc.) (you can also view this in bar graph format) 

 To view all of the other Marxan output files, go directly to the "output" folder for that 

Marxan run (in this case in folder Exercise 1) and open the files with a text editor or 

in Excel to view 

 

9. Independent work – Scenarios 

Make sure to start every new scenario with the following steps: 
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1. Create a new folder with the scenario name 

2. Copy the entire contents of the Marxan_database folder into the scenario folder 

After you’ve created a new scenario you can safely edit your scenario – most Marxan 

parameters can be accessed through the Marxan window in ZC. 

9.1 Scenario 1 – Calibrating the species penalty factor (SPF) 

Above you checked the conservation feature targets in the summary report (indicated by 

the missing values).  There were probably many features that did not have their targets 

met. To meet all of the conservation feature targets, you may need to increase the 

species penalty factor (SPF).  In this scenario you will learn how to calibrate the SPF 

using the calibration tool.  The calibration tool allows you to easily explore a range of 

values for some of the key Marxan parameters.   

 

 After you copy the database to create a new scenario, create a new ZC project 

 Calibration requires more than 10 runs to give a clear picture of how to set a 

parameter – if you are calibrating for a project, it is a good idea to calibrate with 100 

runs (for the purpose of this course, we will use 50 runs to save time, but the resulting 

values will not be as 

accurate as they would need 

to be for an actual analysis) 

 In the Marxan window, 

under the “Marxan 

parameters to edit” heading, 

select “NUMREPS” and 

type “50” into the “Edit 

value” field to set the 

number of runs to 50 

 From the main menu select “Marxan” > “Calibration” (the window below will appear): 

 

 
 

 Select “SPF” from the “Choose Input to Calibrate” menu 

 Specify “10” values in the “Choose number of values” box 

 In the “Range of values” field, use “1” as a minimum and “300” as a maximum value 
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The “number of values” specifies the number of SPF values that will be tested, with 

different values selected in equal intervals from the range specified.  Since you do not 

know how high the SPF will need to be to meet all of your targets, you need to test a wide 

range.  

 

 Click “Run Calibration” 

Note: Depending on the speed of your computer, you might want to go have a cup of tea 

because it will take a few minutes for the calibration to run 

 

 After the calibration runs are complete you will see a summary table similar to the 

table below.  Note that the average number of missing values in a test drops towards 

zero very quickly.  

 

 
 

 To use the graphing functions built into ZC, select “Text Table” > “Graph Table”  

 Graph SPF on the X-axis and missing value on the 

Y-axis 

 

When choosing an appropriate SPF value, look for the 

areas of the graph where the average number of 

missing values approaches zero.  This will give you an 

idea of where the efficient SPF value should be set.  

This calibration narrowed down the potential 

appropriate values, but now you will need to look at 

your graph, choose a range of values where the 

missing values are approaching zero (e.g., 30-200), 

and run another calibration.   
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 Choose the value range that looks appropriate from your graph (it may or may not 

look similar to the one on the right), and run a new calibration with the new value 

range 

 Graph your results and choose the lowest SPF value that allows you to meet nearly all 

of your targets (e.g. average missing value is less than 1).  

You could continue to refine this value with additional calibrations, but for the sake 

of time in the course, we will choose a value after two calibrations.   

Note that you can choose a value where you are nearly meeting all of your targets if 

you are using the Boundary Length Modifier (BLM) to increase the clumping in your 

solution.  This clumping usually will help meet the rest of the conservation feature 

targets without needing to set an inefficiently high SPF.  However, if your objective is 

to use a BLM of zero, you would need to continue calibrating the SPF until all of 

your targets are met.   

 

Record your chosen SPF here: ______________ 

Note that the instructors will ask you to share your chosen SPF value as part of a 

calibration discussion 

 

9.2 Scenario 2 – Variable Boundary Length Modifier (BLM)  

Here we will explore how increasing the emphasis on compactness (that is increasing the 

value of the BLM) affects Marxan results.  

 

 After you copy the database to create a new scenario, create a new ZC project 

 Set the SPF value you chose from Scenario 1 (located in the SPEC portion of the 

Marxan parameter to edit drop down menu) 

 In the Marxan window, select “BLM” from the “Parameter to edit” drop down menu 

 Choose a new value of BLM – the higher the BLM, the more “clumped” your 

solution will be (the parameter can be edited by changing the value in the  “Edit 

Value” field, and then saving the change by click “Save Parameter”)  

 

 

 

 For speed during the course, set your NUMREPS for this scenario to “10” – in an 

actual Marxan analysis you would likely use 100 

 Make sure your GIS map is set to a Solution (not Selection Frequency) 
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 Experiment with several different BLM values (suggestion: 0.1, 1, 10, 100) – to try to 

get to a level of clumping that you think might work for implementation and 

management of reserves. Watch the GIS window map update to see the increase in 

clumping.  

9.3 Scenario 3 – Calibrating BLM 

In this scenario we will be looking at the calibration of the BLM within Marxan.  The 

calibration tool allows you to easily explore a range of values for many key Marxan 

parameters.   

 

 After you copy the database to create a new scenario, create a new ZC project 

 Calibration requires more than 10 runs to give a clear picture of how to set a 

parameter.  If you are calibrating for a project, it is a good idea to calibrate with 100 

runs.  For the purpose of this course, we will use 50 runs to save time, but the 

resulting values will not be as accurate as they would need to be for an actual 

analysis. 

 Set the NUMREPS to “50” 

 Set the SPF to your previously calibrated value 

 From the main menu select “Marxan” > “Calibration” (the window below will 

appear): 

 

 
 

 Select “BLM” from the 

“Choose Input to Calibrate” 

menu 

 Specify “10” values in the 

“Choose number of values” 

box 

 In the range of values, try 

“0” as a minimum value and 

“20” as a maximum value 

 

The “number of values” 

specifies the number of BLM 

values that will be tested, with 
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different values selected in equal intervals from the range specified.  After the calibration 

runs are complete you will see a summary table similar to the table to the right. 

 

 To use the graphing functions built into ZC select 

“Text Table” > “Graph Table” 

 Graph “Cost” on the X-axis and “Boundary Length” 

on the Y-axis. Remove the check mark from the 

“Minimum zero” box.  

 

When choosing an appropriate BLM value, look for the 

steep areas on the graph where the boundary length is 

quickly reduced for a small increase in cost.  If that 

value does not produce the desired level of clumping, 

shift to a higher BLM (knowing that this includes a 

trade-off in terms of cost).  

 

 Choose the value that looks appropriate from your 

graph, and run Marxan with the new value (note that your graph may or may not look 

similar to the one shown here).   Observe the change in the level of clumping with the 

new selected BLM value. 

 

Record your chosen BLM here: ___________ 

Note that the instructors will ask you to share your chosen BLM value as part of a 

calibration discussion 

 

 In the main menu, click “Marxan” > “View output” > “Summary” > “Report” 

 Review the report – are you meeting all targets now?  If not, you will need to increase 

your SPF 

You can also calibrate the number of iterations necessary to get efficient solutions.  You 

would need to do this by hand by choosing a range of iterations values (e.g., 1 million to 

100 million) and a number of tests to do within that range.  The appropriate value for 

iterations will occur when the score in Marxan is no longer greatly improving 

(lowering) with additional iterations.  Try this if you have some extra time today, as it 

is necessary as part of the calibration process for a real Marxan analysis. 

 

9.4 Scenario 4 – Updating planning unit status 

In Marxan, planning units can be never included (or “locked out”) in the Marxan 

analysis, or can be fixed and always included (“locked in”) in Marxan solutions.  See 

Table 1 for the different planning unit status options.  For example, planning units located 

in existing protected areas could be locked in as it is unlikely that areas already protected 

will be traded for other areas. On the other hand, planning units intersecting with ferry 

routes, for example, could be locked out from a reserve system since it is improbable that 

these routes would be modified.   
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Table 1. 

Status Number 

Available for inclusion in reserve system 0 

Included in starting seed and available 1 

Locked in 2 

Locked out 3 

 

There are a number of ways to change the status of your planning units.  You can do this 

in ZC or in ArcMap (or QGIS) by editing the planning unit layer (in this case the 

pulayer_BC_Marine).  Below we will show you a way to do it in ZC.  For more examples 

see the Appendix at the end of this handbook.  

 

 After you copy the database to create a new scenario, create a new ZC project 

 Set your SPF and BLM to your calibrated values 

 In the Marxan parameter to edit drop down menu, choose “PU” – note that all of the 

planning units have a status of 0 (available) 

 Select a block of planning units (you can use the shift button to select many at once) 

and change their status to 2 (locked in). Make sure that the “edit all rows” box is not 

ticked.  Why would some planning units be locked into a solution?  What impact 

might that have on the solutions? 

 Run Marxan and view the results with the locked in planning units 

 Now try locking out (setting the status to 3) a number of planning units and re-

running the analysis 

 Explore the output files to see if files are still achieving targets after you have locked 

out a group of planning units 

 If they are not, try increasing the species penalty factor (SPF) in the spec.dat file.  As 

you increase the SPF, more emphasis will be placed on meeting the conservation 

feature targets.   

In some cases it is possible that you won't be able to achieve all your conservation 

targets because with planning units locked out of the solution; for example if more 

than 70% of one of the conservation features was locked out.  

 

9.5 Scenario 5 – Changing Targets 

 After you copy the database to create a new scenario, create a new ZC project 

 Set your SPF and BLM to your calibrated values 

 Edit your targets in the spec file – increase targets to all features to 50% 

 Check to see if your targets are still being met, and compare with the 30% target 

results 

 Experiment with different targets to see how that changes the solutions 
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9.6 Scenario 6 – Interacting with output 

There are instances where it is useful to alter a Marxan solution, for example to avoid a 

particularly contentious place, as an exercise when meeting with stakeholders, or to make 

boundaries implementable.  The configuration editor in ZC allows users to make changes 

to Marxan solutions, and then generate target/cost summary reports based on the new 

configuration. In this way, you can see how the changes you have made impact how well 

the solution meets your targets, and how it impacts the cost of the solution.  New 

configurations can also be sent back to Marxan for additional analysis.  

 

 After you copy the database to create a new scenario, create a new ZC project 

 Ensure that the NUMREPS parameter is 

set to “100” 

 Set your SPF and BLM to your 

calibrated values 

 Run Marxan 

 From the Main menu select “GIS” > 

“Edit Configurations” 

 Enter a name for the new configuration 

 From the Seed configuration drop down 

select “Marxan Solution 1”.  The seed 

configuration allows you to load a 

Marxan result into the configuration 

editor.  

 From the main menus select “GIS” 

> “Select with” > “Mouse” 

 Use the mouse to highlight a group 

of planning units on the map 

 Change the “assign to” status to 

“Reserved” and Click “Save” – 

you have just changed the status of 

these planning units to reserved  

 Click “Report” to open the 

reporting tool 

 Tick the box next to all the reports 

that you would like to generate, 

and click “OK” 

 

You can also select planning units based on attributes of the planning unit shapefile. 

 

 From the main menus select “GIS” > “Select with” > “Query” 
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 After creating your selection, click “new selection” to select those planning units.  

(the query above will select those planning units with a selection frequency of less 

than 25) 

 Assign the selection to a new status (not selected, reserved, excluded) and click 

“Save” 

 Generate new reports to see the impact of changing these planning units 

 

9.7 Scenario 7 – Installing R and exploring cluster analysis 

Zonae Cogito is compatible with the free statistical computing and graphics software, R. 

You can download this software for free from the R website: http://www.r-project.org/.  

You will need to install packages to make R work with your Marxan outputs (see Day 1 

Handbook for information about these packages).  Zonae Cogito is configured to run R 

automatically when it is installed on your computer (unless you could not log in as an 

administrator, in which case R and ZC will likely not communicate).  The outputs include 

a 3-dimensional plot of the solution space, a 2-dimensional plot of the solution space, and 

a dendogram showing the dissimilarity of Marxan solutions.  

Note: R and packages should be already installed on your computer.  

 After you copy the database to create a new scenario, create a new ZC project 

 From the main menu in ZC select “Marxan” > “Do Cluster analysis” (or make sure 

that it is checked on) 

 Run Marxan, and the 3-D graphic output should automatically appear  

 To view the other R outputs, go directly to your scenario 7 output folder and view the 

“output_2d_plot” and “output_dendogram” images 

If you don’t see any of the graphic outputs you may need to install the packages again:   

 Launch R  

 From the main menu in R choose “Packages” > “Set CRAN mirror” and select a 

location near you 

 Then choose “Packages” > “Install Packages” and select the 4 files: "labdsv", "rgl", 

"tkrgl" and "vegan" (hold ctrl to select multiple items at once) 

 Then from the main menu in R choose “File” > “Open script”, navigate to your 

Scenario 7 folder and choose “Script.R” 

Note: The source might change depending on the where the script.R file is stored, and 

the scenario that you are working on. 

 Copy and paste the script into the R Console and the script will run automatically.  

 

This is the end of Day 2 activities. For more, please go to "Extra_Activities" folder. 

Thank you for your participation in the course! 

 

http://www.r-project.org/
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Appendix 

A. “Locking in” planning units in ArcMap 

In this case study, we included a Rockfish Conservation Area (RCA) found the Scott 

Islands that need to be included into the reserve system (note that there are more RCAs in 

this area, but we included only one for simplification).   

 First we select those planning units in pulayer_BC_Marine layer that intersect 

with the RCA polygon, using Select by Location tool in ArcMap 

 

 Then open the attribute table of the pulayer_BC_Marine and note that a number of 

planning units have been selected.  

 

 Add a new Field and named "RCA" and select "Short Integer" as type value. 

 

 Right click on the new field and select "Field Calculator", and add the value of 2 

(locking in planning units) to the new field.  

B. “Locking in” planning units in QGIS  

In this case study, we included a Rockfish 

Conservation Area (RCA) found the Scott Islands that 

need to be included into the reserve system (note that 

there are more RCAs in this area, but we included only 

one for simplification).   

First, we calculate the amount of RCA found in each 

planning unit: 

 In the “Plugins” menu, select “Qmarxan”, then 

click “Calculate Conservation Values”. 

 On the form that displays, set “Select Planning 

Grid” to “pulayer_BC_marine”, 

 Set “Select input layer type" to “Area”, 

 Set “Select layer to measure" to 

“RCA_Scott_Islands”, 

 Set “On intersection use the following value” 

to “Measure (count, length, area), and 

 Set "Enter New Measure Field Name" to 

"RCA", 

 Your form should then look like the figure to the right: 

 Now click "Ok" to calculate the amount of reserve in each planning unit.  

 When it is finished running, click "Close". 
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Second, we populate the status field (“pu_status”) 

with a value of “2” only for those planning units with 

a RCA value greater than 0 (that is, that intersect with 

RCAs). 

 In the "Layers" list on the left, right-click 

“pulayer_BC_marine”, then click "Open 

Attribute Table", 

 Click the "Advanced search" button in the 

bottom-right corner of the attribute table 

 On the form that displays, double click the 

"RCA" field, 

 Click on " > " operator, 

 Click in the "SQL where clause" window, and 

enter “0”. This will select all those planning units where the RCA is present  

 Your form should then look like the figure below: 

 Click "Ok"  

 

To view selected values check “Show selected only” 

box in the bottom-left of the attribute table. Now we 

will give a value of “2” to the “pu_status” only to 

the selected, as follows:  

 On the form that displays, click the "Toggle 

editing mode" button   

 Now click the "Open field calculator" 

button:  

 Select "Update existing field", set it to " 

pu_status", 

 Click the "Expression" box, type "2". 

 Your form should then look like the figure to 

the right. 

 Now click "Ok" to set a status of "2" to selected planning units, which are 

occupies completely or partially by a RCA. 

  Now click the "Toggle editing mode" button  to switch off edit mode, 

 Click "Save" when prompted to save the changes to the planning unit attribute 

table, 

 Click the "Unselect all" button  to de-select the planning units whose status 

you have just set to "2", and click "Close" to close the attribute table window. 


